Switch to full style

Saturday Haul R&R

Seek advice, give advice or tell others about your repair and restoration projects

Re: Saturday Haul R&R

by SpidersWeb » Sat Mar 15, 2014 3:13 pm

I need to clean the disk drives I've been using, but for the life of me, I can't find where I put my brand new bottle of isopropyl :S The Wang seems extremely picky, and only one of my spare 360KB drives will work with it (and that one is having trouble writing disks accurately). I did get it booting, however nothing on screen, and each keypress accessed the floppy again - so my thoughts are it had trouble reading the equivilent of COMMAND.COM (it loads a MENU program instead of COMMAND.COM) and had bought up a Press any key to try again message - which if true, leaves me with the issue that perhaps MS DOS for the Wang never intended for the serial port to be used as console. So many unknowns. There is great kits for sale in the US with full working units, all the disks, and all manuals - but postage just isn't a realistic option.

In other news, pulled out my 'dead' IBM 5160, set up the camera and started showing the usual procedure for tracking down a short.
I couldn't find one. Plugged it back in, and it fired up :S (5 minutes earlier it was dead). Maybe I bumped something??

Apparently it's fine again. I've left it running, I should go check on it.

Edit: it's fine, also I've confirmed my Commodore 101 key keyboards are auto XT/AT switching - that's handy because I have a few of them.
Edit2: 5160, between not working and working I had removed the serial card and never checked for shorts on -12 or 5V lines - that could be an explanation. I was only watching the +12V line (that's usually where I find shorts) when removing the cards one by one - serial was the only one I forgot to reinstall afterwards.
Edit3: it was the IBM Parallel / Serial card - 3 pin Tantium capacitor - showing 0.02 ohms (it's mates are fine, just one bad cap)
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1130
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: Saturday Haul R&R

by SpidersWeb » Sat Mar 15, 2014 5:23 pm

Used a Shugart 360 which originally came out of another Wang PC.
Used it to write DOS 2.1 disk image, changed DS to '1' instead of '2', wired it up.

It boots fine but I need a screen :( It seems once MS DOS starts, it's not interested in using the serial port as an output device any more. I would do CTTY COM1 - but this version of DOS is very different to what you see on PCs. Looking at what I can off the disk, it starts an alternative to COMMAND.COM - uses a special Wang interface instead - I could get it to run COMMAND instead - but then what baud rate do I use? (There is no MODE.COM) Does CTTY work? Do I use COM1 or SER1 as the device name? etc etc - lots of questions.

I could likely wire up a Multisync display to the plug, but preferrably need a Wang monochrome display (from a terminal or Wang PC). I also don't have a Multisync - seems to be rather hard to find. It's 800x300 @ 60Hz - so HSync is too low for most modern displays, and VSync is too high for most older displays.
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1130
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: Saturday Haul R&R

by tezza » Thu Mar 20, 2014 7:00 pm

I sounds like that Wang is hard work Jono. Still, these more unusual office machines do make a good change from the bog-standard PC compatible.

Just an update on the C16 and Plus/4. I now have a compatible SD21EC (a SD card-based 1514 disk emulator) for it (works on the C64 too) so I'll be able to collect software banks for both. I've even ordered one of those joystick converter plugs. When that arrives I'll be set to really explore what's been written for it (and make the obligatory video too of course!).
Tez (Terry Stewart) (Administrator)
Collection: http://www.classic-computers.org.nz/col ... /index.htm
Projects and Articles: http://www.classic-computers.org.nz/blog/index.htm
Twitter: @classiccomputNZ | YouTube: Terry Stewart
Trade Me: tezza5
tezza
Site Admin
 
Posts: 2293
Joined: Thu Jan 01, 1970 12:00 pm
Location: Palmerston North, New Zealand

Re: Saturday Haul R&R

by SpidersWeb » Fri Mar 21, 2014 9:02 am

Excellent! I've been learning quite a lot about them from your threads, much more than I would have if they were left with me. Great to see them alive, can't wait for a video!
If you ever need spares for the C16 yell out, I still have the other one with missing keys, it'll likely get stored.

Getting the Wang running is difficult because I'm missing bits (like a screen!) but I really do have to give it credit - it's a brilliant machine.
While working with it, I haven't had to change a single switch or jumper on the machine or it's cards (just my PC drives because they're configured differently) - it's a case of "slot it in" - even a second hard drive controller just slots in without any fiddling about. No starting address on RAM cards either, no twisted cables, etc

I noticed the floppies that wouldn't work correctly all had one thing in common - the terminator was missing off their PCBs - so I think that might be the cause. The Shugart (set to DS0 with terminating block) is working a treat.
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1130
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Previous

Who is online

Users browsing this forum: No registered users and 4 guests