Switch to full style

Ram turbo interface faulty

Seek advice, give advice or tell others about your repair and restoration projects

Ram turbo interface faulty

by RonTurner » Tue Feb 11, 2014 5:35 pm

Just recieved ram turbo interface for spectrum, faulty

Tried in on couple of spectrums, they won't boot with it installed,
jus comes up with garbage , any ideas?

Why do I sometimes feel like I'm trying to bucket water out of the titanic ?

Next thing I purchase is gonna work, odds are in my favour :roll:

Two steps forward one step back :?

Seller showed it working so I'm at odds to explain, my interface2 causes
the same effect ?

Is there something I'm missing, do I just need a bigger bucket?
RonTurner
 
Posts: 339
Joined: Tue Dec 17, 2013 9:43 pm

Re: Ram turbo interface faulty

by acsi » Tue Feb 11, 2014 6:42 pm

What version of the spectrum are you using it on?
'acsi' on trademe
acsi
 
Posts: 258
Joined: Sat Jan 07, 2012 2:03 pm
Location: Wellington

Re: Ram turbo interface faulty

by RonTurner » Tue Feb 11, 2014 8:08 pm

48k rubber keyboard , then spectrum+

Makes me real nervous dealing with these things connecting directly to the CPU
etc, you can cause instant death to the computer

My currah speech cart works.
RonTurner
 
Posts: 339
Joined: Tue Dec 17, 2013 9:43 pm

Re: Ram turbo interface faulty

by acsi » Tue Feb 11, 2014 8:48 pm

Hmm strange that both the two interface cards don't work and the cur rah does.

The most common fault with these as you know is dirty contacts. I would suspect the computers ones are fine maybe the connectors on the two interfaces are dirty or they could have solder joint issue's?

I've just checked the PCB's of mine and both look like the solder joints connecting the edge connector are not that strong.

Other than that there is not allot to them. One chip in the Interface2 and two in the Ram turbo. Interestingly my Ram Turbo has damage on the PCB next to the main chip and has wires soldered to bypass this.
'acsi' on trademe
acsi
 
Posts: 258
Joined: Sat Jan 07, 2012 2:03 pm
Location: Wellington


Who is online

Users browsing this forum: No registered users and 2 guests