Visual 200 Terminal Adventure

Seek advice, give advice or tell others about your repair and restoration projects

Visual 200 Terminal Adventure

Postby SpidersWeb on Fri Nov 13, 2015 12:06 am

I like this adventure naming scheme we've got going :P

Image

I've had this thing for at least a year now, and never quite made it around to working on it. It arrived with a little rust, and a cut off power cord.
Even when I did start working on it I couldn't find any information at all beyond an original advertisement and people's fond memories.

I'll post up more photos over the weekend, but mentioning it now because I had a bit of a win tonight.

Quick list:

- one of the large 2200uF caps had blown off the board taking the trace with it, cap was fine, so I bridged it with solder to recreate the original trace, and used hot glue to keep the cap in place
- a 74LS series IC was burning hot, replaced this with a fresh component from another board
- resistance on +5V line kept getting lower and lower after each power on, so tantalum capactiors were removed (resistance went back up and remained stable) before I got shot in the eye
- used an oscilliscope to verify HSync and VSync signals - but no video feed, and nothing on the CRT
- visual inspection of CRT board, nothing stood out
- used oscilliscope to check the RAM chips were getting and sending signals (easy with 4116's because there is seperate Data In and Data Out pins)
- removed chips to see if conditions changed - they did - 3 symptom modes - flashing Caps Lock, flashing ON, no lights - so it was doing something - symptoms often varied for no reason on some occasions, rarely I'd also get beeps on cold starts
- replaced NEC 780 (Z80) CPU and CPU socket - symptoms now consistent - with everything fitted, ON light was flashing on keyboard, no more weird beeps.
- found a Texas Instruments CPU/Graphics controller chip and it's 8116T DRAM - ordered replacements as the TI chip fell apart when I removed it from the socket
- contacted Herb who sells/scans S100 manuals, and had a Visual 200 user manual, turned out a successful POST results in the CAPS LOCK light turning off - which it was. He also mentioned that the system should display a white cursor and nothing else on startup.
- suspected video circuit, so installed new TI chip
- quickly reassembled while my wife was watching, gave her fair warning it might go bang but ended up saying "oh wow, I've got a steady ON light, what's on the screen?" "a white box" she said!

I still need to test the EIA (RS232 in cool kid talk) interface works, and need to put all new foam pads in the keyboard, but I'm extatic with the fact that this 1981 workhorse is alive again.
I'm also amazed the 34 year old video board, which relies heavily on electrolytic capacitors and large current flows, works without any adjustments.

Quick video I shot on my cellphone before I had to come back inside: https://twitter.com/BaudBand/status/664723410719604736
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1126
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: Visual 200 Terminal Adventure

Postby SpidersWeb on Sun Nov 15, 2015 12:37 am

First thing I looked at today was the keyboard, I'd been warned previously it was a Keytronic but I was surprised to find inside that only one key had actually gone bad - most of the foam pads were still foamy and doing the job. To eliminate it being a possible trouble maker, I've left them seperated, cleaned the circuit board, and am just using my fingers (which works fine with these). I can't get any characters to appear on the screen while typing unfortunately, but I can activate system functions such as On/Local, Reset, Caps Lock etc so I know the presses are working on the system is getting the message.

Image

The keyboard is fairly simple, two basic ICs, under the covers an extra LED and IC socket are hidden - I believe these were for the "Block Mode" upgrade.

Then I wanted to see if the serial interface could be probed in to working, and I remembered a $1 toy I got off trademe a while back that was a touch overkill, but I actually had a great time just using it for a practical purpose. It's an HP Protocol Analyser with an RS232 breakout board. I programmed it to send various messages across the serial connection:

Image

But wasn't having much luck. Configured as DTE, the Visual 200 wasn't interested, and configured as DCE the Visual 200 would repeat back the exact same characters (slightly offset by about two characters at 300 baud). So something is wrong on that side of things - finding the fault could be time consuming as there is no circuit diagram available. I now have the original reference manual, but beyond CRT adjustments and how to program the terminal, it's best advice is "Replace logic board". So now I'm tracing signals with the scope, and trying to work out how the interface should operate - since it seems to fail on send and receive I'm trying to find a part that's responsible for both. There is no UART in this design, it's all 74 series logic, a couple of 75 series bus transievers, and an 8116T baud generator (which originally I thought was 8116 DRAM - and got confused when my new 8116 chip was too small for the socket :oops: ).

So it powers up, passes it's self test, and displays a cursor, but I can't quite get any text on the screen. If I can't find anything specific, I'm just going to order one of each logic IC and replace one by one.

ImageImageImageImage
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1126
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: Visual 200 Terminal Adventure

Postby tezza on Sun Nov 15, 2015 8:49 pm

Great writeup.

I have a soft spot for these terminals having sat in front of one for hours and hours for data analysis when I was a grad student!
Tez (Terry Stewart) (Administrator)
Collection: http://www.classic-computers.org.nz/col ... /index.htm
Projects and Articles: http://www.classic-computers.org.nz/blog/index.htm
Twitter: @classiccomputNZ | YouTube: Terry Stewart
Trade Me: tezza5
tezza
Site Admin
 
Posts: 2291
Joined: Thu Jan 01, 1970 12:00 pm
Location: Palmerston North, New Zealand

Re: Visual 200 Terminal Adventure

Postby SpidersWeb on Tue Nov 17, 2015 12:34 pm

Cheers.
If only the staff turned them off at night! Has Victoria University burned in to the tube lol

Did some thinking and investigating, and I think I've got a bad TTL chip that results in traffic being directed in correctly.

Incoming serial should go to the 8251, then back in to the video buffer, but I think the "lane" isn't being switched, so instead of sending it to the video buffer it ends up being resent as serial. Just theorizing. I did follow the RS232 signal through a transeiver and through a few TTL chips (looking up the datasheet for each as I go along) but eventually got lost - I'm just going to replace the chips (and test on removal) in the area between the 8251, 8116T baud generator, and port itself - then we'll see.

I did replace an overheating 74LS32N in that area earlier on, and to follow a trace I did remove a 74S08N right next to it - which I have tested as failed - but I may have damaged it on removal so it may or may not be related.

It doesn't do 244 or 245's (which are used in PC gear a lot) but this has been quite handy for the price: http://www.ebay.com/itm/1PC-IC-Tester-7 ... Sw-dBTt7HG
Cheap IC tester ex-China. Does 74 TTL and 4000 CMOS,
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1126
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: Visual 200 Terminal Adventure

Postby tezza on Tue Nov 17, 2015 1:00 pm

Thanks for that link. I might get one of those IC testers. It's better to use that than my Apple II+ clone for such things. Does it do 4114 and 4164 DRAM as well?
Tez (Terry Stewart) (Administrator)
Collection: http://www.classic-computers.org.nz/col ... /index.htm
Projects and Articles: http://www.classic-computers.org.nz/blog/index.htm
Twitter: @classiccomputNZ | YouTube: Terry Stewart
Trade Me: tezza5
tezza
Site Admin
 
Posts: 2291
Joined: Thu Jan 01, 1970 12:00 pm
Location: Palmerston North, New Zealand

Re: Visual 200 Terminal Adventure

Postby SpidersWeb on Tue Nov 17, 2015 3:41 pm

There is a 74 TTL series DRAM chip, but other than that, no memory options unfortunately. I haven't cycled through the 4000 options yet, but I suspect it only covers the basics, but for the price it's a neat tool to have lying around.
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1126
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: Visual 200 Terminal Adventure

Postby SeanKennedy on Tue Nov 17, 2015 8:05 pm

SeanKennedy
 
Posts: 120
Joined: Thu Jan 08, 2015 9:38 am
Location: Christchurch

Re: Visual 200 Terminal Adventure

Postby Jman on Sun Nov 22, 2015 8:31 pm

Jman
 
Posts: 22
Joined: Fri May 15, 2015 9:24 pm
Location: Christchurch


Return to Repair and Restoration

Who is online

Users browsing this forum: No registered users and 3 guests