IBM Portable 5155

Seek advice, give advice or tell others about your repair and restoration projects

IBM Portable 5155

Postby cjr on Wed Feb 27, 2013 9:05 pm

I stupidly offered to look at one of these for a colleague and the forums seem to suggest this thing is likely to blow up if I plug it in as-is.
As far as I can gather it's been sitting in storage for a lot of years so I asked that he not just plug it in so it's potentially still undamaged right now.
Any suggestions what to check before shoving some juice up it? Tips for someone with little free time will be preferred. :)
Is it even worth it? (I'm fairly indifferent on the whole early PC thing to be honest, I already did my time repairing them back in the early 90's.)
trademe:cjr
cjr
 
Posts: 64
Joined: Sun Feb 05, 2012 8:57 am
Location: Wellington

Re: IBM Portable 5155

Postby tezza on Wed Feb 27, 2013 9:25 pm

Hmm...Are they easy to open up? If so I would open it and check for cables which might have come loose etc. These don't have a battery do they? Then ,explain to your friend the risks (i.e. things might go pop) and if he accepts them, just fire it up and see what happens.
Tez (Terry Stewart) (Administrator)
Collection: http://www.classic-computers.org.nz/col ... /index.htm
Projects and Articles: http://www.classic-computers.org.nz/blog/index.htm
Twitter: @classiccomputNZ | YouTube: Terry Stewart
Trade Me: tezza5
tezza
Site Admin
 
Posts: 2293
Joined: Thu Jan 01, 1970 12:00 pm
Location: Palmerston North, New Zealand

Re: IBM Portable 5155

Postby SpidersWeb on Thu Feb 28, 2013 8:00 am

I'm in Wellington, and have had my fair share of IBM pops and bangs , if you/they wanted assistance.

First off they're just an IBM 5160 PC-XT in a box, with exception to the display, any details on the 5160 motherboard will apply here too.

There is a chance it'll just work but the common things are:

- line filter caps in the PSU - not necessary for operation but make lots of smoke and a loud bang - this wont hurt anything - my 6150 didn't even blink when this happened (although I jumped like a girl). If these haven't blown already, it's very likely they will within the first second to 15 minutes.
- tantalum caps - if shorted the PSU wont start but if it DOES start and they're dry they'll explode like little flaming projectiles - once removed the PC will run - there are common caps which fail which can make repair easier - I've never had pops or removals cause problems.

Edit 3: if a tantalum launches itself, make sure it's remains don't cause a short on the motherboard

To test for shorts on the motherboard, basic resistance measurements can be done at the power connector. If you get 0 ohms between a + connection and ground - you know you'll need to remove some tantalum caps (I have spares btw if he wanted to replace dead ones). Generally though, just plugging it in will perform this test for you - if shorted you'll see the fan just 'nudge' a tiny bit rather than spinning up.

To test the power supply, remove it and connect it to a sacrificial motherboard (I have a 286 board I use), and maybe a hard drive - this is just to make sure it doesn't vomit out 30 volts or something - I haven't had this happen yet - but if you were being super careful and had the time it's a good practice. Good time to crack out the multimeter and check the voltages are in range too.

Personally I just plug them in and see what happens, but how careful you wish to be is up to you.

Unfortunately I'm unfamiliar with the display side of things as that is unique to the 5155, although I've found that IBM displays don't seem to suffer many problems if any, so chances are that part of the system will be ok.

If it has a hard drive fitted and you get it running, use Norton Calibrate (or similar) to perform a non-destructive low level format on the hard drive - often I get MFM units that have been sitting in garages for years, they work fine for 10 minutes then start losing data, so I get in their with my maintenance before they have a chance.


Sorry for the long post, I'm quite passionate about my IBM stuff lol

Edit: I just noticed your 'little free time' - in that case just plug it in - but as above, make sure he knows that a bang is quite likely.

Edit 2: if you can't get it to power up properly and don't have time I'm happy to take a look, I can make room on the workbench
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1130
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: IBM Portable 5155

Postby ZL2AOX on Thu Feb 28, 2013 10:13 am

This reminds me to make up a little dummy load for testing PSUs. Or perhaps several, to cater for the different power ratings.

Not that I've actually experienced a failing PSU also damaging the mainboard, but it's always a possibility.
ZL2AOX
 
Posts: 74
Joined: Sun Sep 12, 2010 12:30 pm
Location: Palmerston North

Re: IBM Portable 5155

Postby cjr on Thu Feb 28, 2013 7:14 pm

It's nice to know they're generally robust, maybe I will just turn it on and see what happens.
I wonder if vic20 is still looking for a 5155. :)
trademe:cjr
cjr
 
Posts: 64
Joined: Sun Feb 05, 2012 8:57 am
Location: Wellington

Re: IBM Portable 5155

Postby SpidersWeb on Thu Feb 28, 2013 8:25 pm

I'm missing a 5155 in my spot too, and a 5170 (got the case LID and motherboard, but need the rest argh)

Let us know how you get on. If you have a video camera handy, should record it!
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1130
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: IBM Portable 5155

Postby SpidersWeb on Mon Mar 04, 2013 4:23 pm

*poke*
Plugged it in?
Wanted - Dead or Alive - Reward $$$: Compaq Deskpro 8088 / 286 / 386 - IBM RT 6150/6151 parts - AT&T 3B2 parts
VC Twitter
SpidersWeb
 
Posts: 1130
Joined: Tue Jan 24, 2012 8:38 am
Location: Wellington

Re: IBM Portable 5155

Postby cjr on Mon Mar 04, 2013 9:10 pm

Nope, the one and only hour I found spare in the weekend was spent hotting up my Amiga 1200 with an 030@40MHz.. zoom
Maybe this weekend.
trademe:cjr
cjr
 
Posts: 64
Joined: Sun Feb 05, 2012 8:57 am
Location: Wellington

Re: IBM Portable 5155

Postby acsi on Mon Mar 04, 2013 9:12 pm

Bit off topic but I take it that 030 was the card on trademe which was sold as not working? Did it work OK or did you need to fix it?
'acsi' on trademe
acsi
 
Posts: 259
Joined: Sat Jan 07, 2012 2:03 pm
Location: Wellington

Re: IBM Portable 5155

Postby cjr on Mon Mar 04, 2013 10:26 pm

yes, it worked fine.. was a bit of a gamble though. :)
trademe:cjr
cjr
 
Posts: 64
Joined: Sun Feb 05, 2012 8:57 am
Location: Wellington

Re: IBM Portable 5155

Postby acsi on Tue Mar 05, 2013 7:35 pm

I had a sneaking suspicion it would.

Congrats that's a good score.
'acsi' on trademe
acsi
 
Posts: 259
Joined: Sat Jan 07, 2012 2:03 pm
Location: Wellington


Return to Repair and Restoration

Who is online

Users browsing this forum: No registered users and 4 guests