System 80 Expansion units from Hell!

Seek advice, give advice or tell others about your repair and restoration projects

System 80 Expansion units from Hell!

Postby tezza on Tue Oct 19, 2010 10:34 pm

I'm continuing to work my way through this System 80 haul and now have two working expansion units :)

One was always ok, but the other one could only recognise the last 48k bank of memory and the floppy disk controller didn't work. The problem? A pin had been puched out of an IC turning off the lower 32 bank and a small wire jumper had been removed which stopped any data reaching the floppy disk controller IC!!

Of course I only discovered these "modifications" after a number of frustrating days with scope and logic probe trying to figure out what the @#$% was wrong!

These System 80s came from a school. They were 32k units so I guess the lower 32 bank in the expansion unit was disabled to stop people filling them with RAM thereby setting up a conflict with the RAM already installed under the keyboard. What's more, only one floppy drive system was available for all the computers. Apart from the master computer then, all others would only need expansion units for 48k memory and as somewhere to place the monitors. Maybe that's why the floppy controller was disabled..to stop kids plugging drives in!

Given that one of the expansion units had both banks of memory active and the floppy controller working, perhaps it was from the Master machine?
Tez (Terry Stewart) (Administrator)
Collection: http://www.classic-computers.org.nz/col ... /index.htm
Projects and Articles: http://www.classic-computers.org.nz/blog/index.htm
Twitter: @classiccomputNZ | YouTube: Terry Stewart
Trade Me: tezza5
tezza
Site Admin
 
Posts: 2293
Joined: Thu Jan 01, 1970 12:00 pm
Location: Palmerston North, New Zealand

Re: System 80 Expansion units from Hell!

Postby tezza on Fri Oct 22, 2010 8:52 am

For those that are interested, I wrote this up as a couple of blog articles. The first one is here..
http://www.classic-computers.org.nz/blo ... ts-ram.htm

I'll post up part two when I've finished it. Both show how after-market modifications can make diagnosis difficult.
Tez (Terry Stewart) (Administrator)
Collection: http://www.classic-computers.org.nz/col ... /index.htm
Projects and Articles: http://www.classic-computers.org.nz/blog/index.htm
Twitter: @classiccomputNZ | YouTube: Terry Stewart
Trade Me: tezza5
tezza
Site Admin
 
Posts: 2293
Joined: Thu Jan 01, 1970 12:00 pm
Location: Palmerston North, New Zealand

Re: System 80 Expansion units from Hell!

Postby tezza on Sat Oct 23, 2010 9:36 pm

The second part of this fix.
http://www.classic-computers.org.nz/blo ... roller.htm

Both boxes are working now :)
Tez (Terry Stewart) (Administrator)
Collection: http://www.classic-computers.org.nz/col ... /index.htm
Projects and Articles: http://www.classic-computers.org.nz/blog/index.htm
Twitter: @classiccomputNZ | YouTube: Terry Stewart
Trade Me: tezza5
tezza
Site Admin
 
Posts: 2293
Joined: Thu Jan 01, 1970 12:00 pm
Location: Palmerston North, New Zealand


Return to Repair and Restoration

Who is online

Users browsing this forum: No registered users and 4 guests

cron