Apple IIc IWM Chip Issues

Seek advice, give advice or tell others about your repair and restoration projects

Apple IIc IWM Chip Issues

Postby mazwreck on Thu Jun 02, 2016 3:48 pm

Hey everyone

So this is my issue with my Apple IIc that ive had even since getting this from my brother. I do know it did work fine for him but once i got it never worked correctly and once i found about ADT Pro i thought sweet ill power get the Apple IIc out again and fire it up as i like to play some of those games on there. Sadly some of my original disks no longer work/have issues so i thought well i can also reprogram a set of disks from images but sadly due to this fault i can't

What happens is with "Any" formatting program even with ADT Pro it refuses to format disks. Originally way back when i through was the disks them selfs so i recently bought some new/old stock ones but still the same issue hmmm ok.

Now how i worked this out was yesterday after mucking about with different disks (new/old) and different programs still refused to format. I thought ok if both drives are doing the same thing the controller must be faulty. I pulled out the Apple IIe for a quick run and found that all new/old disks worked and formatted fine so can rule disks out. I also cleaned both drives and swapped them around but still caused the same issue which points me to the IWM chip

Looking at the IWM chip and main pcb i couldn't see any track rot/damage from age so i went about and put my scope on pin 8 of the IWM and noticed once it goes into formatting mode its stuck low doing nothing on scope hmm interesting.

Got the schematics out and noticed that pin 8 only goes to the internal floppy disk controller connector so i thought must be a internal issue with the chip so put my ohm meter from pin 8 to GND/+5 and noticed from 8 to GND i was getting a solid reading of 0.60 ohm not good. What this was telling me was that the chip is always in the stuck state so doesn't matter what you do it will never work correctly.

Knowing this a good friend of mine did a test for me on his and told me that on his working system there is open no short no ohm reading so quickly removed the chip from PCB and found out of circuit still had that .60 ohm issue.

I thought ok cool i finally found the issue now where do i get a chip after 3 hours of looking about i found that this chip is really hard to come by easy well in my country anyway so i had 2 options, Find another faully Apple/Mac that uses this part and remove it or find someone O/S that may have one from a scrap system.

Lucky enough i came across this seems its like a auction site of some sorts anyway sent the seller a message and he is happy enough to send one to me so fingers crossed this fixes my issue, If it does't then i am back to square one but i really can't see any other issues that "may" cause this

Posts: 2
Joined: Wed Jun 01, 2016 8:53 pm

Return to Repair and Restoration

Who is online

Users browsing this forum: No registered users and 8 guests