Page 1 of 1

Acorn A310 help.

PostPosted: Mon Feb 03, 2020 1:58 pm
by nzjavert
I recently got my hands on an Acorn A310 with riscos 2 in bits. I have tried to power on the computer but will not display anything. I Looked online and the most common problems seem to be c37 tantalum capacitor, power supply, and the typical acorn battery leakage issues.

I have replaced all 3 capacitors with 25v 100uf caps as this is the standard go to repair to see what is wrong.
I have fitted a new battery holder and new batteries.
I have also checked the output of the power supply on each rail and am getting the correct 12v, 5, -5v on the correct pins.
I have reseated all the removable ic's.

I am not getting any display or any beep on boot up. I have tried the cmos clear (hold delete when turned on until it boots) and this does not do anything.
the caps lock and num lock lights turn on and off when pressed. the floppy drive does not flash but the light does stay on.

that is about as far as i can go without help. Does anyone have any ideas or had similar issues that could point me in the right direction.

Any help would be greatly appreciated.