Page 1 of 1

IBM RT PC 6150

PostPosted: Sat Feb 09, 2013 3:13 pm
by SpidersWeb
So I picked up the beast today. Lots of goodies.

IBM 5151 unscratched
IBM 6150 tower base unit (with a LOT of serial ports off the back)
IBM 6157 tape drive and cable
Spare hard drives - including a 380MB Maxtor 5.25 full height and a 30Mb full height from a Compaq??
Spare 1.2MB floppy drive
IBM 6151 documentation and all 3 diagnostics disks
IBM AIX 2.2 books + installation disks (there is a LOT of disks)
IBM Model M keyboard
Chicony clone keyboard - an exact replica of the original Model F for the IBM AT except a little lighter and it has an XT/AT switch
Some other random keyboard - cross between XT and AT - 10 function keys but it has a numeric keypad.
Boxes of goodies like OS/2 Warp 3 manual, Netware CDs, Windows NT4, 127MB IDE, SoundBlaster Pro (sweeet)
Wyse WY-50 terminal (but no keyboard, damn it)

I also poked the Zilog - under the flap is a tape drive btw - no floppy.
Owner is a nice guy, he used these machines to run terminals back in the day.

But the best thing is I just powered it up. It worked first go :S I'll take a video of the startup sequence. There is something about a machine which waits to power up the hard drive that makes it an experience. The whir of the fans, the LCD diag readout checking over, then up comes 14 and a few seconds later the sound of a 5.25" full height ESDI drive roaring to action.

It's heavy as heck though, to move it more than a few metres I'd recommend two people.

Re: IBM RT PC 6150

PostPosted: Sat Feb 09, 2013 3:30 pm
by SpidersWeb
Left it on for a few seconds too long I think ;) Room smells like smelly capacitor.
Machine kept running, and with smoke location and odour I'm guessing a mains line filter.

It tries to boot, but I think the hard drive is no longer reading. No flashing error codes during/after IPL and all the codes line up with the machine's configuration. On the display I just get a cursor - need to connect a keyboard and try a diagnostics diskette.

Re: IBM RT PC 6150

PostPosted: Sat Feb 09, 2013 7:48 pm
by SpidersWeb
Not quite a Model M keyboard - it has a speaker and an "Action" key. Funky six pin plug, that goes deep in to the back of the machine.

Just booted it up off the IBM PC RT Diagnostics diskette. So it's functional but I suspect a blank/dead hard drive. You have to be patient at boot time - took a while before I got to see an IBM logo!

Edit: disk past all tests, I rebooted (CTRL+ALT+BREAK btw) and decided to have some patience - after a while AIX 2.2.1 booted up. Now I realise the downside to restoring UNIX systems, it is perfectly configured for it's 16 terminal ports (custom driver) and tape etc etc but I don't know the correct username/password to actually use it. So used to DOS where it just drops you in! I tried the obvious, no luck.

Re: IBM RT PC 6150

PostPosted: Sat Feb 09, 2013 11:49 pm
by SpidersWeb
Hacked in (thanks to maintenance disks)
Computer says I can get a 4G63 balance shaft for $41.

Long story short, it works.

I now have root access.

Re: IBM RT PC 6150

PostPosted: Mon Feb 11, 2013 6:50 am
by SpidersWeb
Added a second H310 hard drive - came spare with the machine - it spins up then down then up then down - bah. Gutted because the noise was awesome on startup as each drive engaged and I can get 3 x 5.25 FH drives in that case (connectors just sitting there at the ready). I have a Miniscribe version of the H310 to try (drives MUST be identical when connected internally) so I might get a second drive after all or be stuck with a single and cross my fingers it doesn't fail at some stage. I'm guessing I wont be finding SpinRite for AIX in a hurry.

Also discovered it's been upgraded to a 135 model - it has the Enhanced Advanced CPU card and I beleive 16MB Fast ECC RAM.

I haven't confirmed it 100%, maybe it was a fluke, but mine would not spin the hard drives up with the front cover removed AND if drive D fails, you can't use Drive C either (IBM actually designates them C D E in the manuals, it's not the DOS coming out in me).

Also learned it wont boot AIX without it's precious keyboard. It wont throw an error either, just sits there. This could've been a fluke but certianly explains why it never booted the first few times and I'd read it elsewhere (so don't take it as hard fact, it's just what I beleive, could've been a fluke).

Oh and the internals are clean, no battery goop.

p.s. when reattaching the front panel, don't get your finger between the side panel and front panel, it hurts.
p.p.s just realised that second data cable has been sitting unused for 25 years - wonder if the second drive just failed because of a poor connection, might be worth investigating

Re: IBM RT PC 6150

PostPosted: Mon Feb 11, 2013 2:29 pm
by Corestore
Nice job!

I have... somewhere between 2 and 4 of those, but the desktop flavour.

Never been powered up, were old and somewhat rusty when I got them 15 years ago, never did a thing with them - just shoved them in the 'future projects' pile. Now I know someone with a working one, I might just have a hack... in my copious free time!


Re: IBM RT PC 6150

PostPosted: Tue Feb 12, 2013 6:57 am
by SpidersWeb

Might be a handy tool for your setup too, seems they were often used to connect Big Iron to smaller iron.

I had spent an hour with my machine last night, hard drives are being picky.

C: original H310
D: extra H310
E: Miniscribe 9834E

First off:

C: spins up fine
D: spins up and down
Machine will not see C and not boot.

Then I added 'E':

C: spins up fine
D: spins up fine (wtf)
E: spins up fine but RT Diagnostics did not see it

I left it to boot AIX and did something else for a while (10 minutes), came back and C wont respond anymore

C: doesn't spin up at all
D: spins up fine (sounds new now)
E: spins up but doesn't register

and of course I get code 22 (boot record not found) and it hammers the heck out of the floppy drive until you give it attention - it's like a 3 year old banging pans until someone picks him up.

So I am hoping it is just a loose connection on the C drive - otherwise I'm going to have to prepare about 30 1.2MB disks.
When all 3 drives were spinning, the noise was epic, almost a gig of storage :) Would be over a gig too if hook up the tape drive - just nervous to plug it in - those line filter caps argh.

The good thing about all this is, my spare 310Mb drives appear to be in a working condition. The miniscribe was from a Compaq, so it's likely I need to boot off the VRM disk and give it a low level format.

Re: IBM RT PC 6150

PostPosted: Wed Feb 13, 2013 6:02 am
by SpidersWeb
Disconnected the Miniscribe (Drive E) and resecured/adjusted the cables to the two Maxtor/IBM H310 drives - I've now got 620MB of storage!

I'm having trouble getting it to mount in AIX - it certainly appears that IBM didn't expect people to just whip in another hard drive as there is a bit of a procedure in getting the partitions to appear in /dev. There is an AIX partition on it marked /hd10 (discovered using maintenance disks) but I don't think hd10 will appear under /dev until VRM is configured to look for it.

VRM is a device driver that goes between AIX and the system unit. I'm not a huge fan - it also gives me an error when booting which I think is because I haven't connected the tape drive (it has it's own independent power supply, so I've been putting it off).

At least it's booting again - I'm still not exactly sure what was preventing C from coming online - but it was certainly my changes that made the difference (it went from reliably failing to reliably booting after I finished).

Re: IBM RT PC 6150

PostPosted: Fri Feb 15, 2013 6:27 am
by caluser2000
It's progress though. Good work.