Page 2 of 3

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Fri Feb 03, 2012 3:41 pm
by Gibsaw
SpidersWeb wrote:Edit 2: But sadly it has USB ports and there is a 95 USB chip driver under System, but it quite simply can't detect anything on the ports.

Yep, the win95 USB drivers are really just stubs that show the controller is there. The earliest you'll get "working" USB is Win98, and even then it's pretty incomplete and requires drivers to be loaded for even the most basic storage devices. (USB keys, hard disks.)

I think it can handle an MS mouse or keyboard, but that's about it, out of the box.

I do believe win95 can be made to work, as it still does support a PnP architecture, but generally speaking it'll depend upon which version of win95 (i.e. only OEM SR 2.1 and later support USB) it is, and to get it to work properly, you'll generally have to get an updated USB chip driver from whoever made the chip.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Fri Feb 03, 2012 6:30 pm
by SpidersWeb
Yeah I looked it up today, I've got 95a, apparently you:

- Copy Win95 SR 2.1 or 2.5 to hard disc
- Edit config file, and change a 9 to 1
- Run

and it'll upgrade without asking for keys (mode 1)
Supposed to be OEM fresh install only (mode 9)

Will try it later in the weekend. I know I could just wing 98SE on there, but I'm trying to keep it feeling as close to original as possible and apparently some of the bundled software doesn't like 98.
I also found (can't remember link) a third party add in that allows 95C to behave more like 98 with USB flash drives etc. Will see what happens.
I got a USB to PS2 adaptor for my mouse, but still want USB if I can (printer/flash drives).

But today's job is getting a 360 in and getting the network operating :)

Got drive in, and irrelevant of weither I select DS1 or DS0, it always runs at the same time as the other floppy, boo.
Just gonna switch out drives, if the same happens, I'll switch cables.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Fri Feb 03, 2012 7:05 pm
by SpidersWeb
Got the 360 drive fired up (at the right time)
It refuses to format my HD disks though :(
Put tape over the hole, no diff, not even sure if it checks for that.
More diagnostic work to do I guess, would be nice if I had some DD disks to eliminate the surface difference issue, might have to win some auctions. Have two other drives to try, and some isopropyl for some good old fashion hillbilly headcleaning.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 6:40 am
by tezza
Ive forgotten the technical details as to why, but HD disks cannot be formatted in a DD drive. Not unless they are completly demagnitised.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 10:09 am
by SpidersWeb
Yeah know what you mean, just could've sworn I got away with it on many occasions back in the day!
My other drive turned out to be a 1.2Mb, since I can test that (success) I've left that in place. I have a 286 with a 1.2/360 combo coming back late Febv which can be my device for making the PC boot and get files too.

Have been having issues with the expansion cards, working then not working, or one works the other doesn't. Removing the Intel Pro 100 ethernet adaptor seems to have fixed it - I'm unsure if it was the card or if the riser is losing a connection here or there - for the meantime I'll claim ignorance and stick with ISA.

Put in a D-Link PnP ISA 10BaseT and attempted to browse the internets in Netscape 2 :D (was SUPPOSED to be for my T3200SX)
Modem is back in and with the PCI adaptor out, is coming up as a modem in device manager and passed its diags tests and the usual echo ATDT1234 > COM2 etc. But Windows95 keeps getting 'device in use' or 'could not open port' - so I did another restore last night (now that the hardware is back to how it was factory) - haven't tried it out yet - want to setup speakers and vid cam to record the 1996 Compaq promo videos haha.

Took a video of the BIOS etc, but it's not terribly exciting, might upload it anyway later.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 11:20 am
by Carcenomy
I'm confused, why are you specifically wanting to use a DD drive instead of HD? I'm guessing so that floppies made for old hardware work better?

There would have been a reasonably nice software package that went with that Presario out of the box too other than just the promo videos. The 52xx/72xx/92xx (AIO/Desktop/Tower, respectively) family came with Descent and Magic Carpet bundled :)

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 11:56 am
by SpidersWeb
Magic Carpet was on a seperate CD.
So was PGA Gold 96 :(

But I've got MS Works, all the Compaq PhoneFax/VCD + Audio tools, Quicken, Netscape/Compuserve etc

Reason I wanted the DD drive is because I have absolutely zero disks to actually boot the IBM 5150 when/if it starts. I have the Cassette BASIC diagnostics on MP3 I can feed through the cassette port but that's it!

DD and HD on 5.25 are different. The DD has a larger head and provides more write current. Much more reliable at writing DD disks.
Quite common to see 286's with a 1.2 and a 360 B drive - so the users could reliably transfer data from XTs etc.
Media is different too, which is no doubt why I couldn't write 360K format on 1.2 disks :(

But without DD disks at hand, I'm just gonna wait until I get some (about to hop on trademe and get my bid-on)
I have an IBM 5160 XT, 286 clone and 386 clone coming in 3 weeks - the 286 has 1.2 and 360 so I'll just use that to make the 360 boot disks.
Really want to just leave the Presario alone now and I know the 1.2 works sweet, formatted some disks last night.

The other benefit of the Presario and it being on the network, is that I can easily transfer data on to 1.2 1.44 and 720K discs now. I've been having to either burn CDs or borrow works 3.5 USB floppy drive.
If I plug a floppy of any sort in to the FDC on my i7, Windows won't even start.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 1:21 pm
by SpidersWeb
It is making me want to rage :P
With the PCI card removed, and the software reset I can now use the modem, kind of.

CompaqPhone - could not start because of a 'TAPI Error for an unknown reason'
Any other Telephony software wont start because the Compaq Telephone Service driver wont let it talk to the modem.
Terminal software though I just select COM2 and can dial, send AT commands etc.
If I go through control panel I can get the diagnostics from the modem on COM2 no problems now.
From MSDOS I can do echo commands.
From the diags in BIOS I can do an internal test and it comes up 100%.

Modem is in th e oiginal COM2 position, and has nothing conflicting with it.

Yet the software just will not run it in phone mode and does not give me a good excuse or anything to go on.

Going to do some research on the interwebs, and may possibly try a 98SE upgrade to see if that changes anything (can always restore again if it just makes a generic mess).
Network card is behaving as usual.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 1:30 pm
by SpidersWeb
CPQEXCLD.EXE corrects an issue with the PaperPort Software Version 3.53 or earlier that causes COM Port 2 to be unusable. With COM Port 2 unusable, all telephony and on-line service capabilities do not work.

Fingers crossed.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 3:43 pm
by SpidersWeb
Didn't work.
Neither did upgrading the driver to v2.0

Did find the answer in a generic compaq FAQ on uktsupport.
It said it was easy and all you had to do was to remove, reboot, and readd the Compaq Telephony driver.
I did, but it wont let me readd it - tried this before the updates, then did a restore + updates + this method - apparently "Telephony can not do that at this time".

Ran an app that lets me view all the windows processes - including hidden - and closed everything non-Windows. Didn't help.

Fax/Terminal all fine, only when you use the TAPI driver, but the telephony features are what make this machine interesting :(

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 5:26 pm
by Carcenomy
Again I'm referencing my own machine, but it's sounding more and more like ours are nearly identical in most respects.

If so, my modem required a cable that connected it to the motherboard which I believe was some form of linkage between the modem and the sound hardware. You'll know if this is the case, there'll be a header on the modem if it used this setup.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Sat Feb 04, 2012 8:34 pm
by SpidersWeb
Cheers for that, no connection cable and checked the documentation for the modem - its a full voice card and transmits over the COM port - 11Khz mono and supports a large array of voice AT commands.

But got me thinking hardware so did some playing. After removing the modem from control panel, I tried to readd the Telephony device and got the same error but this time I got it instantly instead of 10 seconds later. So I'm guessing it was querying the modem - unable to do what it needed - and that's the failure.

Seems odd though because when I reinstalled it, Windows correctly detected that it had a wave generator etc (which gets added as audio in/out options like a sound card would). Would LOVE to know what is causing the failure specifically but the telephony stuff just seems to have almost no error output.

Will give up on this one, and just use it as I originally intended rather than trying to restore it to it's former answering machine glory.
Sad though, had so many crazy features :/ Can even set it so that if I already have X number of messages, to start picking up the phone quicker becuase I'm obviously out. Soooo many features like that, and the flashy new messages light :(

Guess I should just be glad I have a BIOS again :)

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Mon Feb 06, 2012 11:31 pm
by SpidersWeb
Since 'as original' wasn't working out, I formatted it with Windows 98 SE fresh (which is working awesome and way way more functional).

Had trouble with the ISA cards. Modem was OK but my D-Link DE220 10BaseT (which was working in Win95) would get detected, setup and reported as working correctly, but it wouldn't send any network packets out (or receive them, not sure which, possibly both). Removed both ISA devices, put back in the Intel Pro100 PCI network adaptor - worked perfectly.

Think the PnP ISA or ISA connectors themselves in that machine might be a litle screwy. PCI card on it's own just works 100% with no dramas at all.

Another funny (but also annoying) thing I found, was to free up an IRQ I'd disabled COM1 in the BIOS. But then you boot the machine and Windows95 or 98 just find it and turn it back on! Somewhat used to the BIOS being more like "off" rather than using a PnP request to be quiet.

Anyway, machine going great, browsing the interwebs, playing old games, GUI BIOS doing it's thing, and the 5.25 works great, all is well.

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Mon Feb 06, 2012 11:40 pm
by tezza
Your adventures remind me of those bad old days before plug and play in the PC world (late 80s/early-mid 90s). IRQs, memory conflicts, card/driver incompatibilities, expanded/extended memory....aargg!! No wonder the Mac people were so smug and (insufferably) superior! :D

Re: Compaq Presario 4780 who stole my BIOS?

PostPosted: Mon Feb 06, 2012 11:50 pm
by Carcenomy
He's just reminding me that the 7222 needs a couple of VRAM modules replaced ;)